VisualGroups Web Extension kann nicht geladen werden, wenn der Benutzername Sonderzeichen enthält (UTF-8 Code >128)

Enreach Info
Enreach Info
  • Aktualisiert

Symptome

VisualGroups Web Extension kann nicht geladen werden, wenn der Benutzername Sonderzeichen enthält (UTF-8 Code >128).

 

Ursache

Das Visual Groups OCX codiert den Benutzernamen in UTF-16, der IIS dekodiert dies jedoch in UTF-8. Dadurch entsteht eine falsche Zuordnung, wenn ein Benutzername Sonderzeichen enthält also insbesondere ä,ö,ü,ß usw.

 

Lösung

Das angehängte OCX File codiert den Benutzernamen in UTF-8 bevor er mit einem Hashwert zum Server zur Authentifizierung geschickt wird. Dadurch wird diese falsche Zuordnung der Zeichen vermieden.

1.) SwyxIt! Und ClientLineManger schließen

2.) IpPbx.VisualGroups.WebExtension.ocx im Verzeichnis “C:\Program Files (x86)\SwyxIt!” durch das im Anhang ersetzen

3.) Swyxit! wieder starten.

War dieser Beitrag hilfreich?

0 von 0 fanden dies hilfreich

Haben Sie Fragen? Anfrage einreichen

Kommentare

0 Kommentare

Zu diesem Beitrag können keine Kommentare hinterlassen werden.