Remote inquiry sometimes does not find any voicemails when MS Exchange is used

Enreach Info
Enreach Info
  • Updated

Symptoms:

Sometimes Remote Inquiry does not find any voicemails when Microsoft Exchange 2007 or 2010 is used as mail server.

Cause: 

SwyxServer uses IMAP4 to retrieve voicemails from a user's email inbox. To do this, a standard IMAP4 query is used asking the mailserver to return mails with a specific header. Microsoft Exchange sometimes executes this query without error, but does not return any result. 

Resolution:

 If you have this problem you can configure SwyxServer with the following registry key to not query with specific header lines, but to retrieve all emails and filter voicemails locally:

Path HKLM\SOFTWARE[\Wow6432Node]\Swyx\IpPbxIMAP4\CurrentVersion\\Options
Type REG_DWORD
Name FetchOnlyVoicemails
Value 0
Description If zero IMAP search will be done without querying for X-IpPbx… Header.

 

Note: With this setting SwyxServer retrieves the complete email list of a user's inbox on each remote inquiry. Only email headers are retrieved, but nevertheless performance could suffer if the inbox contains a lot of emails.

More Informations:

Another cause for this problem could be the Exchange Header Firewall sein. See Remote Inquiry maybe doesn't work with MS Exchange 2007

 

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